PlanetMinis Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,632 Posts
Discussion Starter · #1 ·
If anyone could tell me since I got a 03 xr 50 running a sano pipe and kn air filter and I have cleaned the stock carb out and still did not fix it. It runs on choke only and still bogs so its needs more fuel for sure.



So let me know what main and etc.



Thanks
 

·
Registered
Joined
·
481 Posts
I doubt you need to rejet. Make sure that your jets, are free of debris, and check your diffusers as well.. Adjust your clip on the needle, place clip all the way down to richen her up. Adjust the idle screw and the air/fuel mixture screw 1/4 turn at time and see how she reacts.

I would also check valve clearance, it only takes few mins.

Its too cold to be tuning bikes this time of year tho..
 

·
Registered
Joined
·
694 Posts
yellowrider said:
I doubt you need to rejet. Make sure that your jets, are free of debris, and check your diffusers as well.. Adjust your clip on the needle, place clip all the way down to richen her up. Adjust the idle screw and the air/fuel mixture screw 1/4 turn at time and see how she reacts.

I would also check valve clearance, it only takes few mins.

Its too cold to be tuning bikes this time of year tho..


Good Advice

I had the same problem. I got a UNI filter and a yoshi exhaust. I lowered the clip and it works better. I also ordered the jets so I could try playing with that. I did my valves and that helped alot too. Also make sure the engine is warm before you make adjustments
 

·
Registered
Joined
·
33 Posts
make sure ur pilot jet isnt clogged and richen up/raise the slide needle (lower the clip). In general, the pilot circuit controls idle to 1/4 throttle & the slide needle controls 1/4 - 3/4 throttle after which the main jet takes over. you may need a fatter pilot jet.



bogging is usually a too rich issue where rat tat tat is usually too lean. if all else fails, put a new plug in and do a plug chop and see what the color it is. black = too rich, white = too lean..
 

·
Registered
Joined
·
2,632 Posts
Discussion Starter · #6 ·
Well I am sure its not the valves since bike has very low hours. Thats just like when I had a z400 quad everyone said you had to adjust the valves. My valves were fine it was the cheapo jap timing chain that stretched like a mother and I put in a DID heavy duty one and no more noise from the top end.



Bike sat for a long time and the bowl and the inside of the carb had a type of red dust in it from the old gas that smelled very old. Took everything apart and cleaned with hog wash carb and choke cleaner and put back together. Played with the idle and a/f screw and nothing help. Bike will run on the half choke setting. Full choke it dies and no choke it does also. So it starving for fuel since with some choke on you can rev it to the moon but without choke it will bog and kill it unless you throw the choke on.



So what size jets do I need and where can I get them from. I will take the carb back apart and see what size is in there tomorrow. I am sure with no airbox and a exhaust it needs a rejetting. Also if someone has some jets let me know or even a carb setup for a air filter and pipe let me know.



Thanks
 

·
Registered
Joined
·
33 Posts
before i bought my 20mm carb kit, i put a K&N on my stock carb and had to drill out the main jet up a size to a .60, the stock is a .58 if you dont get a jet kit, you can get a pin vise from a hobby shop / sears and drill it out in .02 mm increments until you hit it right.
 
1 - 8 of 8 Posts
Top