PlanetMinis Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
I have a stock xr50 motor with BBR full exhaust and uni air filter. Should i go up on main jet or whats the best way to tell and get best performance. I heard rev up and then kill the motor and then check plug to see color. If any of you have a good starting point let me know on what jets to start with. Thanks.
 

·
Registered
Joined
·
756 Posts
The bike will properly run better with the stock pipe modded, do a search on that and the plug chop, generally though the jetting will be fine.



How is it running?
 

·
Registered
Joined
·
473 Posts
i would try getting a bigger main jet and then going from there..mess with the air screw also. maybe try a 62 main jet and lower the needle one notch.
 

·
Registered
Joined
·
191 Posts
is it running fat with the pipe?





just play around with the clip position..





I just got my buddies stock motor..stock pipe with a filter runnin great.

it was running lean as hell from the factory
 

·
Registered
Joined
·
95 Posts
Discussion Starter #6
It runs ok just feels real slugish i have another one that is stock with stock pipe and filter and its alot better thats why i am asking
 

·
Registered
Joined
·
191 Posts
Scott D said:
It runs ok just feels real slugish i have another one that is stock with stock pipe and filter and its alot better thats why i am asking
it must be running really lean..

it's pulling more fuel in..and you gotta keep up with it

check the stock specs and get the next size up or two jet,

i'm sure the clip position will fix it though. try that first



or play with the air-fuel to you hear the smoothest rpm all the way around..

someone messed with my buddies...cuz it wasn't even close to how it shoulda been on a stock bike..and I just fixed it today..I forgot how many turns it was..sorry.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #8
UndefinedT said:
it must be running really lean..

it's pulling more fuel in..and you gotta keep up with it

check the stock specs and get the next size up or two jet,

i'm sure the clip position will fix it though. try that first



or play with the air-fuel to you hear the smoothest rpm all the way around..

someone messed with my buddies...cuz it wasn't even close to how it shoulda been on a stock bike..and I just fixed it today..I forgot how many turns it was..sorry.
Did you go up or down with the needle clip?
 

·
Registered
Joined
·
191 Posts
Scott D said:
Did you go up or down with the needle clip?
I didn't move the clip,

he has stock pipe with a small K&N filter,

someone fcked the air mixture up..I turned it all the way in, then did 2 1/4 turn out I think..

then turned down the idle,

and revved the motor up..rode it pinned in 2nd and killed it and checked the plug..looked fine..but the plug is weak.



and he said it ran good minus the weak plug
 

·
Registered
Joined
·
191 Posts
Scott D said:
Ok cool i will have to mess with it see what i come up with. Thanks
Goodluck,





I also took his carb apart, and cleaned it out..it was dirty at the bottom of the bowl...some debris in gas or stuff got sucked in..



make sure the float isn't bent and it returns properly also.



careful when taking out the air mixture screw if you do..there is a spring. if you lose it, your screwed.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #12
Yea i pulled the carb off and cleaned it but it was pretty clean so that made no diffrence so i am going to mess with the needles and clip.
 
1 - 12 of 12 Posts
Top