PlanetMinis Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
557 Posts
Discussion Starter · #1 ·
The past few weeks, ive been noticing more and more blue smoke coming out the exhaust. My friends and I were thinking about it and decided to take the head off. We noticed that the oil pump seal was kinda ate through. I replaced that and it still is smoking. I just bought a TB88 standard kit with the cam and 20mm carb about 3 months ago so the rings cant be broke. Any ideas of what it could be?? :roll: :roll:
 

·
Registered
Joined
·
1,355 Posts
check your oil
 

·
Registered
Joined
·
3,787 Posts
I can eliminate some things I dont think it is. Certainly not low on oil, highly doubt it could be the rings, as we installed them perfectly, same as my motor and mine has 150 hours on it no prob, and I dont think it would be the crankcase breather, he keeps the bike really clean and the breather hose is pointing downward so it would be hard for anything to get in there and stay. I myself was thinking the same as goinonfiddy, that the valve guide seals may be cooked. When we installed his kit we never put in a hv oil pump, so his motor has always ran pretty hot, im thinking that there might not have been enough oil flow to the head to compensate for the extra excesive heat and baked the valve guide seals into leaking like there isnt anything there. It is currently smoking, REAL bad, almost like a 2stroke.
 

·
Registered
Joined
·
557 Posts
Discussion Starter · #17 ·
thats what it was. the exhaust valve guide seal was cracked. Thanks for the info, we were thinkin it was the valve guide seals but i just wanted to make sure. thanks!
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top