PlanetMinis Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
got my sano frame the other day, let me say its a thing of beauty......but when we installed everything on it last night the plastics didn't line up right......the tank sat too far forward, and when we slid the seat and shrouds to it there was a huge gap between the tank and the seat.....everything was lined up correctly....the clips under the seat where in.......it almost seemed as if the bracket under the seat near the rear was too far back........Is there some thing I need to do to the seat or the tank to make this all fit snug again...........
 

· Registered
Joined
·
464 Posts
mine did that, i just took my time and pushed the seat a bit forward and just worked with it till it went in.
 

· Registered
Joined
·
94 Posts
Discussion Starter · #6 ·
this is an old post, but I ended up having to notch the front mount for the tank so I could slide it all the way back.......I quadruple checked everything and it just didnt line up right........it works now but I was a little shocked to see it wasnt going to line up........other than that the frame is rock solid and I have absolutely no complaints and will continue to buy sano products in the future..........
 

· Registered
Joined
·
134 Posts
doesn't the same company make sano, five-0 and red baron frames.. cause they all look alike. 8O
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top