PlanetMinis Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
lately ive noticing oil seeping somewhere under the head and running onto the exhaust studs. it seems to only happen after long hard rides. ive retighten the head bolts and still leaks. blown head gasket? bike seems to run fine. anyone ever have this happen to them? any thoughts or ideas would greatly be appriciated.
 

·
Banned
Joined
·
1 Posts
Check the head side cover? A leak there will run down. Otherwise, easy enough to grab a top end set and re-seal it all, to save chasing a leak around.
 

·
Registered
Joined
·
2,150 Posts
and double check you have acorn nuts on the studs. I bought my bike and the guy had used regular nuts so it seeped oil out from there. If so just make all 4 acorn nuts looks better anyways. if everything is tight and right hardware just have FPM get you a top end gasket kit
 

·
Registered
Joined
·
113 Posts
Discussion Starter #4
firepower354 said:
Check the head side cover? A leak there will run down. Otherwise, easy enough to grab a top end set and re-seal it all, to save chasing a leak around.




yea side cover is tight. i have tbs 88cc kit with race head. kit only has about maybe 8-10 hrs on kit and its leaking already??
 

·
Registered
Joined
·
113 Posts
Discussion Starter #6
firepower354 said:
I've got about 20 times that on mine, and it's dry... I've never seen one leak when correctly assembled and torqued.


I followed danosbike instructions to the t. Anything wrong with those?
 
1 - 7 of 7 Posts
Top