PlanetMinis Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
624 Posts
Discussion Starter · #1 ·
I starting leaking oil on Sunday while at a mini-moto. There was oil residue on the top of the cylinder and down the sides. There would be enough at the end of a 10min session to leave a few drips in the floor. The skidplate and peg mounts were covered too, my catch can was also full. Today I checked all nuts and bolts on the motor to double check and all was up to spec. I also changed the oil to make sure that there was exactly 1qt of oil for next time. Any ideas??
 

·
Registered
Joined
·
624 Posts
Discussion Starter · #3 ·
I thought about that but why would they start leaking now? They are about 60days old and have several hours on them. I would hate to tear my motor apart just to check.
 

·
Registered
Joined
·
624 Posts
Discussion Starter · #5 ·
Its both. I bought it new and put the 134 kit in with a engine tech. He's built several

110s and this is the first issue.
 

·
Registered
Joined
·
111 Posts
maybe the oring on the valve tappet cover. clean all the oil off of it, take it on a little ride and see where the oil is coming from. What is your catch can connected to the crankcase breather, if so there was to much oil in it but that wont explain oil on the head. did you check your oil after your discovered the leak to see how much was left in the bike.
 

·
Registered
Joined
·
624 Posts
Discussion Starter · #9 ·
I didnt start the mini-moto with an empty can so its hard to tell how much was from Sunday. And when I drained the oil there was about a 1/2 in the glass viewer. I think that I am going to have to trouble shoot this over a few rides.
 
1 - 9 of 9 Posts
Top