PlanetMinis Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
sup everyone.. i have a crf50 with tb's 88bore kit with race head with about 25 hours on it...it was tuned and everything.. and then one day when i mashed on it hella hard it wouldn't keep idle... the only way it would stay on is if i give it hella gas and then die when it gets to low rpm's.. so i took it home and took the top end apart everything's fine piston and valves and camshaft are in great shape i put my stock 50 carb on the race head to see if it holds idle... it starts up perfect and holds idle.. so basicly its my tb's carb that got messed up.... i'ma clean it again right now and see if it does anything... but everyones advice would be greatly appreciated!



thanks in advance



ohhh and i looked at the sparkplug... its really dark (rich) so i'm guessing an airway is blocked.. but we'll see after i clean it again aight thanks!
 

·
Registered
Joined
·
2,149 Posts
sounds like a jetting issue but i would clean the carb as it sounds like the pilot jet might be plugged. Make sure you blow the jets out with error or stick a wire through them to make sure its clean and get any dirt out of the bowl as it could just clog it up again. Also did you let the bike sit for a long time as gas will gel if it sits a long time. Take carb cleaner to get the film out if thier is any in thier. Let us know if that helped the problem out.
 

·
Registered
Joined
·
344 Posts
That sounds like your problem but try to pull the air screw all the way out and clean it, along with blow some air into the hole. Sometimes that passageway can get clogged and that will make it run rich.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top