PlanetMinis Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
5,897 Posts
Discussion Starter · #1 ·
Well I have a hydro clutch kit from motoHP on my 110.I love the clutch and all but the bolt where the hydro line goes into the cover kills my foot.I weat Thor 50/50s and actually get black and blue marks on my foot from it.I was wondering if anyone else has had this problem before and if you did what you did to fix it.



I was thinking about getting some carbon fiber cloth and making like a guard type of thing.Also is there a bolt setup thats smaller than the current one I have?
 

·
Registered
Joined
·
54 Posts
Banjo Bolt

If you contact BBR, they are now including a lower profile banjo bolt with their kits for this exact reason. I am not sure if you have to get another line or not, I don't think so, but if you do I know that it isn't all that much? I feel the bottom line is if it is causing you this sorta pain while your riding that it is well worth the investment!! Let me know what Ryan tells you, -Rob
 

·
Registered
Joined
·
1,769 Posts
i noticed it at first, now i don't? maybe i started to position my foot farther outside on the peg but i couldn't say forsure. make sure it's not something like a seam inside your boot that the bolt is pushing on and causing it. if it is try trimming it, i've had that problem b4. if none of this helps you could always get the takegawa special hydro clutch (the line connects to the top of the cover)
 

·
Registered
Joined
·
5,897 Posts
Discussion Starter · #16 ·
You have to rub it in dont you Matt?Let me guess, next your going to post a pic of it with that sick black mag cover?



Bump for a pic of the lower profile bolt.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top