PlanetMinis Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
So my friend just got a klx110 and he is encountering some problems with it, first off the bike starts and runs fine when its cold, bu once it gets hot i will not start again, we thought it was because we had a little too much oil in the engine(about 100mL) but even after we changed the oil to get it to the correct height , it still has the problem. Any help??





Also his bike will randomly leak oil out of it from weird places, but after we clean it it usually will not leak anymore, but we dont know why. We think it needs a new engine case gasket, and maybe a new spark plug but we arent sure.





We are new to the seen and need some help! Thanks!
 

·
Registered
Joined
·
2,535 Posts
might be jetting. my bike was a pain in the azz to start last saturday [temp was around 100], went to a smaller jet and it fired right up and ran like a champ. oil wont have anything to do with it not starting btw.

look around the oil filter housing and drain plug to see if that's where the oil is leaking from.
 

·
Registered
Joined
·
551 Posts
if i was you i would put in a new oil filter and drain plug washer... if oil is coming out of you case its a gasket problame

the running problame is the jets not clean or rong size
 

·
Registered
Joined
·
1,247 Posts
mini rider 140 said:
I don't know how to spell anything correctly.


Fixed.



Basically what mini rider said, check your oil filter and jetting. It could be an electrical problem as well. When its hot check if your still getting spark.
 

·
Registered
Joined
·
678 Posts
A random oil leak that goes away after cleaning the bike could also be the crankcase vent tube. If the bike lays on it's left side very long(ie. a crash) when you pick it up the oil that has collected in the vent tube can then spill out the end leaving oil all over the peg bracket/lower frame/bottom of engine area. might not happen everytime, but not completely uncommon.



As far as the hard starting, check compression and valve clearances
 

·
Registered
Joined
·
114 Posts
Discussion Starter #7
Okay thanks guys!



I think we have the right jetting for it and there are brand new jets so they shouldnt be dirty, he has a fmf 4.1 pipe and a two bros airfilter, so we are running a 95 main and a 38 pilot. Which according to the bbr site is right.



Sooo i think it has to be electrical, we are going to check the spark soon, just havent gotten around to it yet.



Thanks for all the help! Oh and next time we run thw bike and it leaks oil i will snap a pic of it to see what you gus think.



Thanks for all the help guys! We really appreciate it
 

·
Registered
Joined
·
114 Posts
Discussion Starter #8
Thats exactly what it is! It has to be the crankcase vent tube! How could i fix it? Thats exactly what it is doing.
 
1 - 11 of 11 Posts
Top