PlanetMinis Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
I got a FORZA 125cc pitbike and interms of frame and stuff its pretty much the same as a SSR 125 TR. anyway the bike is about near 2 weeks old and have about 8 hours of riding on it so far from offroad and on paved roads.

I used castrol 4t 15-50W NON SYNTHETIC oil and it is on its third oil change to get all the metal fragments out.

About a ride or 2 ago *I ride for around 30 mins each ride* anyway about a ride or 2 ago sometimes when I give it throttle it sometimes feels like it skips something like instead of pulling me forward something slips and it misses the power if that makes sense? so I think the clutch might be slipping. The last ride it seemed to happen more so I think its getting worse. Also half way through the last ride when the engine was still on I stopped at a park and went to down shift through all my gears and even though the bike was on it did not shift down through all the gears while sitting still even though it usually does I had to wiggle the bike back and forward to shift through each gear and then after taking off shifting to gear 2 it felt sticky and I had to push up the shifter a bit harder than I usually do so I dont know whats going on.

today was alot colder and more windy than it usually is so maybe the oil is too thick for these temps? when I ride it before it was at least 25c *77F* but today was really windy and was 19C *66F*
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Ok just went for a ride and when I first started it and went up the hill that is decently big in gear 2 I felt it slip a bit almost a bogging almost but it got better when it warmed up and it was 8 PM so it was about 14c so it was really cold so do you guys think its the oil I used?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top