PlanetMinis Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
i just put on my new bombshells and they arent real plush they kinda stick.i messed with the knob on them but still its sticking.i am thinking its beacause the seals are new and have to get warn in or sumthin.any ideas?
 

·
Registered
Joined
·
938 Posts
maybe they forgot to lube them before assembly? get some 5wt fork oil and pour a little (few drops) into the forks. if you have gen 1/2, then just screw the caps off. if gen 3 then i think theres a little allan bolt on the tops that unscrew and you can lube them through there. just push them up and down a little to work the oil in and see if it starts to feel better...
 

·
Registered
Joined
·
1,426 Posts
they wont be real plush until you ride them do to the spring. But when you ride, you'll defiently feel plushness.



Also, Thormx said it. Loosen the 2 little allen nuts on the top of the fork, and put like 2-5 drops of 5wt fork oil in there. then compress the forks a few times and you'll see the oil.
 

·
Registered
Joined
·
5,829 Posts
I don't own these . Are they a true hydralic fork or a mountain bike type of elastisomer (SP ?) fork ?



All new suspensions needs break in time !!!!

If after a couple of good riges they still do it , contact the manufacturer and hit him up on why the are sticky . :wink:
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top