PlanetMinis Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
TB 88 R/H, Two Bro's Exhaust, TB rev box, Sheng Wey 20mm carb.



So, i have mostly resolved the carb tunning issues, but now another issue has come up. The bike runs pretty well whenever it is started, a little low end bog, but nothing to bad. But when i hold it at about 25mph, probably 5-6000 rpm in third, for about 30-40 seconds, maybe a full minute and a half, it starts to sputter and occasionaly pop and can barely keep speed, and then just dies. Then i leave the bike alone for 10 or 15 seconds and i can start it again and run it up to maybe 15 and it starts to pop again. Same thing happens if i do a WOT run up to high rpm in 2nd or 3rd- the bike will just trip over itself until i get slow enough (3 or 4mph) for it to lock the rear wheel.



The bike runs well at 1/3 to full throttle, pulls pretty hard and everything. Until this crap starts to happen. I thought it might be an issue with the float height(which i had to change alot to keep the carb from leaking gas constantly), but if i open the fuel bowl bleed right after it dies, it pours out gas pretty quickly and consistently. Anything anyone can think of? Im already planning on just scrapping the carb and replacing it with the Mikuni VM26 i have on the way when i throw the 108 stroker crank I'm about to buy in the engine, but it would be nice to have it run before then.
 

·
Registered
Joined
·
4,282 Posts
your having a fuel delivery issue. Make sure the line from the carb isnt pinched off somewhere, and that the pep cock is flowing well. Dont take this the wrong way im not being a dick but make sure you have enough fuel in the tank.



I had a C70 that did this and the way the line ran to the tank it couldnt keep up/have enough flow at WOT.
 

·
Super Moderator
Joined
·
9,534 Posts
+1 on the fuel delivery issue. Do you have a vented gas cap, or one with a vent hose attached? Those vent "buttons" on a short piece of hose can clog and prevent the tank from equalizing pressure, and will create a "vapor lock" of sorts, and starve the carb of fuel.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #4
Already checked fuel line, and yes the take is full.

Hmm. Vapor lock. I have the stock gas cap and vent tube on, and theyre both like new, so i dont think thats it. I'll definently check though. Anything else?
 

·
Registered
Joined
·
148 Posts
check ur air filter!! i know it sounds dumb but my bike had the same symptoms. would idle fine get up to speed pretty good then at the top it would sputter and backfire. i checked everything, fuel flow, jet, i even pulled the carb and cleaned it all out, all i could think of, then i pulled my airbox there was grass and dirt clogging the filter, and i also saw a small air leak on the tube that connects to the carb. i epoxied around the tube and put a new af in and now it runs great! i have the stock carb and airbox so i hope this helps.
 
1 - 7 of 7 Posts
Top