PlanetMinis Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I was putting my TB 88cc kit w/race head together when I found out the freaking cable doesn't work with the bbr throttle. It looks like you have to grind about 1 1/2 inches of the outer cable(black part) off to give it enough slack for the carb slide to go down. I guess I'll do that tomorrow. :x Why is it that everytime I put someone on my bike, something doesn't fit right and I have to go out of my way to make it work? This sucks.
 

·
Registered
Joined
·
52 Posts
yea that cable sucks. I cut about 4 inches of the outter housing off for my friend with a bbr. If you can sauder, you can cut the tip off of the inner wire and just slide the cable out and cut the housing that way, then just sauder the tip back on there for the carb. My sano one works barley, its screwed all the way into it and the nut on the cable is just sliding around the cable. I did a fast50s one and it was the same way also.
 

·
Registered
Joined
·
3,787 Posts
A throttle that the cable does work perfectly with is a stock xr70 throttle. I had to get a new one when I put my bars and all so I just got a 70 throttle, mainly because it was cheap, like $12 or something and it works absolutely perfect.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
I got it working now. I had to cut about two inches of the outside material off on the carb side. It was a PITA doing that with a dremel without cutting into the cable but I finally got it.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top