PlanetMinis Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
My friend has a 75 cc big bore kit with a stock ported head and the BBR exhaust with a 20mm carb and also the cam. it bogs and kills when you open it up from no throttle to Wide Open is this normal or is the carb too big or what the main jet is an 85 with a 35 pilot and the needle in the middle position
 

·
Registered
Joined
·
446 Posts
Without a ported head it probably wouldnt work but since the head is ported it may be just jetted wrong. If i were your friend i would take it to a local shop to get it jetted perfectly.
 

·
Registered
Joined
·
1,220 Posts
mine does the same thing...i have almost the same setup...i think its too big..but u will lose the awesome top end it gives you
 

·
Registered
Joined
·
3,787 Posts
Try richening out the pilot. Your not getting enough fuel when you wick it open. Notice why bigbike thumpers have accelerator pumps, so that when you wick it open it gives a little squirt of fuel so it doesnt do that. More than likely youll never be rid of it, you can only make it slightly better, a Inner Rotor or shaved flywheel will also help with getting rid of it as it will let the engine spin up faster.
 

·
Registered
Joined
·
461 Posts
20s to big for a 75! takegawa doesnt even run a 20 on there 88s, even tho it would be better. i woudl say run a 18 with the 75. ported head or not.
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #7 ·
It is not the pilot jet i think it is the main jet because i know enough about carbs to know at which position each jet delivers at my problem is that even if i had the available jets to play with which i dont i am thinking that even if it went lean enough it would do the trick maybe because the carb is delivering too much air as well, BUT i am not 100% sure thats why i am asking if anyone else has encountered this. Also if i did lean it out enough to stop that bog when i would roll on the throttle and cruise around the motor would probably be way to lean and burn up because of that lack of fuel. anyone getting my drift or has no one encountered this yet??
 

·
Registered
Joined
·
379 Posts
put a 78 main in it, the 85 will work for an 88.I ran mine for a year and a half with a 75cc kit and a 20mm carb it is not too big your jetting is too rich

just my 2 cents

rob
 

·
Registered
Joined
·
52 Posts
i have an 85 or an 82 jet (I FORGOT) in my 75 kit, i forgot which one, stock head. runs great,no bogs or drops at top end. I had an 89 in it and the top end would go braaaaa drop braaaa drop.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top