PlanetMinis Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I just bout an 04 too and i have a 20mm carb,and a bbr rev box on my bike (for preformance parts) and i am having the same problems it will idle but once u try to rev it it chugs and sounds like it is getting to much fuel. i know for a fact the carb is jetted right i know i got the right jets in it, but this problem only happens at the tracks. for example i can ride at my house and my buddies houses for hours and the bike runs great but i go to the road to the indoor arena and take 5 laps and i have that problem im not sure what to do......help anyone??? :cry:
 

·
Registered
Joined
·
26 Posts
Is it the head stock and :roll: is the opening of the intake port stock? if so that could be an issue thats alot of fuel that is trying to get thru a small space we had the same trouble a little porting and bam crisp.
 

Attachments

·
Registered
Joined
·
102 Posts
that carb is way too big for a stock 50...........the only thing I can come to is you are in fact getting way too much fuel...........you can try running a hotter plug but I still think its way too rich.......
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
i am running a stock cylinder, the problem still happens even with stock carb, no the tracks are at the same elevation
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
GOOD NEWS!!!!!!



I fixed the problem, well it was kinda by fluke. my buddies were up all night with me try ur guy's ideas and we tried them all but still not working, but then we lost my bbr rev box so we through the stocker on and it fixed it!!!!!





thank u all very much for the help
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top